Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Увеличение цен в прайсе Excel на определённый процент

Автор mixail, 29.06.2014, 09:45

« назад - далее »

mixail

Здравствуйте форумчане нужна помощь, имеется прайс лист с ценами в количестве более 5000 наименований,    нужно цены в столбце увеличить на 35% без формул и макросов так как в прайс установлен калькулятор подсчета итогового заказа  ,   про бывал увеличить с помощью умножения специальной вставки(1,35) вроде бы всё получилось но есть одно но (начальное- 397,65 после 536,8275), вопрос как сделать так что бы после запятой было две цифры а не три или четыре, и если возможно без сложностей ???.!

Можно ещё вопрос в прайс установлен калькулятор (в шапке ) имеется четыре столбца с ценами опт -от10т.р.    от25т.р   от50т.р.  от100т.р.  Как изменить значение 0т10т.р. на от15т.р. от30т.р. от60т.р. от 150т.р. и так нужно сделать на четырёх столбцах и чтобы калькулятор ссылался на количество заказа в деньгах правильно(ориентировался на ценны определённого столбца).  Заранее благодарен за ответы. :)

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

0mega

#2
Цитата: mixail от 29.06.2014, 09:45
   про бывал увеличить с помощью умножения специальной вставки(1,35) вроде бы всё получилось но есть одно но (начальное- 397,65 после 536,8275), вопрос как сделать так что бы после запятой было две цифры а не три или четыре, и если возможно без сложностей ???.!

=ОКРУГЛ(B2*1,35;2)

или можно в любой свободной ячейке записать  и скопировать 1,35
Выделяем все цены - правая мышка - специальная вставка - умножить
А потом как написал Сергей форматнуть ячейки. Но здесь есть свой подводный  камень .
После формата будет отображаться (визуально) 2 знака, но машина будет считать все 4

_Boroda_

А чтобы этого не происходило, можно сделать следующее: сделать форматом столько знаков после запятой, сколько нужно, затем
а. для 2007 и больше - Файл - Параметры - Дополнительно - При пересчете этой книги
в. для 2003 и меньше - Сервис - Параметры - Вычисления -

поставить галку "Задать точность как на экране" - ОК
Потом опять пройти по тому же пути и снять эту галку.
Итог - значения "обрежутся" так, как видны на экране.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

vikttur

Цитироватьпоставить галку "Задать точность как на экране" - ОК
Но очень аккуратно. Действует для всех листов открытой книги. Изменения необратимы.

zs

 а если исходный и итоговый столбцы задать рублёвый формат