Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

ЕСЛИ для списка значений

Автор Shadowmaker, 10.07.2014, 16:49

« назад - далее »

Shadowmaker

Прошу помощи:
Есть длинный список значений (города) и есть таблица с записями на другом листе, содержащими значение "город" в отдельной ячейке. Нужно проверить - совпадает ли это значение "город" с любым городом из списка на другом листе. Если совпадает - проставить 1 и если нет то 0 в отдельной ячейке на соответствующей строке.

Как это можно сделать? Пихать в =ЕСЛИ(И($A1=Города!$A$1;.... 500+ ячеек вообще не вариант - и долго и формула шизанутая. Наверняка это можно сделать как то проще.

vikttur

=--ЕЧИСЛО(ПОИСКПОЗ(город;диапазон;0))
=--(СЧЕТЕСЛИ(диапазон;город)>0)

Shadowmaker

Спасибо!
А что означают 2 минуса в начале формулы?

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390