Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Вопрос: Выборка наибольших значений

Автор пав, 13.07.2014, 20:06

« назад - далее »

пав

#15
Vikttur если правильно понял то формула определят наибольшее знач в шаге (колич строк), который мы предложим. Если так, то возможно ли чтобы каждая формула начиная со строки С4 расширила заданный шаг (колич строк) на 2-ве строки?
К примеру шаг = 100 строкам. формула в строке С3 без изменений. формула в строке С4 начнет поиск не с 101-ой строки а с 99 (то есть на "- 2 строки").
   

vikttur

#16
При таком изменении диапазоны будут перекрываться. Если максимальное значение будет находиться на границе диапазонов, оно будет показано в двух ячейках столбца С. Что-то неправильно в Вашем желании сдвигать диапазоны.


пав

#17
Все как ранее

пав

#18
Был человек и пропал

vikttur

Живой я еще, не лейте горьких слез :)
Не помогаю - написал почему.  Ждите других.

IKor

2 пав

Правильно ли я понимаю, что у Вас есть таблица данных некой функции и Вы ищете максимумы ее значений?
Я предлагаю решение "в лоб"
для ячейки С2: =ЕСЛИ(И(B2>B1;B2>B3);B2;"") и протянуть вниз по всему столбцу C

zs