Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Использование значения ПОИСКПОЗ() в формуле

Автор Shadowmaker, 21.07.2014, 13:42

« назад - далее »

Shadowmaker

Помогите разобраться:
Есть список значений, которые необходимо просуммировать от одной строки до другой.
Номера строк от которой и до которой нужно суммировать найдены при помощи ПОИСКПОЗ() в отдельных ячейках.
Получается что-то вроде

|A             |B|C|
|Название1|32|45|

Теперь эти значения нужно использовать в формуле которая суммирует - как это сделать?

iron priest

это делается тогда, когда есть файл-пример

IKor

2 Shadowmaker

Если я правильно понял, Вам следует обратить внимание на функцию СМЕЩ() - посмотрите прилагаемый файл.

В сторону: формула "лажает" на Петре с Иваном, и ее можно было бы доработать для переходных лет, но пример использования функции приведен.

vikttur

СМЕЩ - функция летуча, поэтому ее желательно применять, если нет адекватной замены.. В показанном файле сумма:
=СУММ(ИНДЕКС(D2:D19;ПОИСКПОЗ(B24;B2:B19;)):ИНДЕКС(D2:D19;ПОИСКПОЗ(B25;B2:B19;)))

Shadowmaker

Последний вариант оказался наиболее применим в моём случае.

Со СМЕЩ разобрался в рамках своего интеллекта - если я всё правильно понял то в моём случае она не применима, потому что расчёт идёт относительно сводной таблицы, в которой количество строк может меняться.

vikttur

В СМЕЩ для поиска границы диапазона ПОИСКПОЗ тоже можно применить.

Czeslaw

Может так как вариант частично исправленная формула от vikttur
=COUNT(INDEX(D2:D19;MATCH(B24;B2:B19)):INDEX(D2:D19;MATCH(B25;B2:B19)))