Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

перенос значений из столбцов в чередующиеся строки

Автор galaxy_hero, 18.08.2014, 01:12

« назад - далее »

galaxy_hero

Здравствуйте.

Возникла специфическая потребность в переносе данных из ячеек.
Имеется таблица со строками

Атрибут1   Значение1-1 (пустая ячейка)
Атрибут2   Значение2-1 (пустая ячейка)
Атрибут3   Значение3-1 (пустая ячейка)

Атрибут1   Значение1-2 (пустая ячейка)
Атрибут2   Значение2-2 (пустая ячейка)
Атрибут3   Значение3-2 (пустая ячейка)

и т.д.......

Значения атрибутов указаны в столбах

Значения_атрибута1          Значения_атрибута2          Значения_атрибута3

Значение1-1                     Значение2-1                     ..........
Значение1-2                     Значение2-2
Значение1-3                     Значение2-3
Значение1-4                     .....
......

Необходимо перенести значения атрибутов из столбцов в строки, где сейчас пустые ячейки. Подскажите, пожалуйста, как это можно реализовать?

на всякий случай прикладываю картинку со скрином. Буду весьма признателен за помощь! )


andrewkard

Если в лоб, то можно быстро не выдумывая формул, напротив каждого атрибута выставляем номер требуемой строки, они будут чередоватся 3,3,3, 4,4,4, 5,5,5, т.е., ставим 3,3,3 потом формулу "=Ячейка+1", три раза, копируем их и вставляем до конца. Потом прописываем формулу =ДВССЫЛ("G" &A3), где G - необходимый столбец, А3- нужная строчка, для каждого. Выделяем, копируем, вставляем до конца.

NooBasTiK

#2
Вы бы пример выложили. Я картинку вашу смотреть не могу т.к. на работе стоит прокси который блокирует различные ссылки и картинки.
Правила форума
Цитировать2. К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.
Прикрепить к сообщению можно только файлы gif,jpg,rar,zip,7z,bas,frm,cls,docx,xlsx,xls размером до 1000 Кб.
Прикрепить файл можно в полной форме ответа на сообщение. Под окном для ввода сообщения нажмите на знак "+" возле текста "Дополнительные опции..."

galaxy_hero

прошу прощения - не заметил, что можно прикреплять - по привычке вылил картинку на сторонний хостинг.

Прикрепляю файл с примером и картинку.

cheshiki1

=ИНДЕКС($B$2:$B$73;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$73=H$1;СТРОКА($A$1:$A$72);"");СТРОКА(H1)))
формула массива. вводим в Е2 и растягиваем.

vikttur

Перенесите Совместимость в столбец D, чтобы порядок параметров был одинаков:
=ИНДЕКС($D$2:$F$73;(СТРОКА(A1)-1)/3+1;ОСТАТ(СТРОКА(A1)-1;3)+1)

galaxy_hero

сработал вариант от vikttur. Сейчас попробую сделать в исходной таблице.

galaxy_hero

все получилось! огромное всем спасибо!!!