Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Формула вычисления процентного расхождения.

Автор Nikita Anatolyevich, 27.08.2014, 09:24

« назад - далее »

Nikita Anatolyevich

Здравствуйте!
Задача следующая:
Есть значение А и значение В.
Необходимо создать условие при котором в ячейке будет отображаться NG или OK.
NG- Если В больше или меньше А на 10%.

Надеюсь на вышу помощь, заранее спасибо.

cheshiki1

это? есть сомнения на счет знака "=" возможно вам придется добавить ">" или "<" в требуемых местах. (запись будет такая B1>=A1*1,1 или такая B1<=A1*1,1)
=ЕСЛИ(ИЛИ(B1=A1*1,1;B1=A1*0,9);"NG";"OK")

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Nikita Anatolyevich

Спасибо, работает, но есть условие, о котором я забыл упомянуть.
Значения могут быть отрицательные и при этом такая формула не работает)

Pelena


Nikita Anatolyevich

Пример:
A= -1,2
B= -1,1
По факту итог "OK", т.к. значение "B" не превышает значение "A" больше 10%, но перемножение отрицательных цыфр дает неправильный ответ.

Pelena

Вы считаете, что в этом примере должно получиться NG? Почему?

Nikita Anatolyevich

Как раз я считаю, что результат  должен быть ОК.
Но предложенные ранее формулы считают иначе.

Pelena

Странно, у меня при таких данных результат ОК.
Прикладывайте Ваш файл с примером

Nikita Anatolyevich

Прошу прощения, я допустил ошибку при написании формулы.
Все работает!
Большое спасибо за помощь!  :D

zs

Цитата: cheshiki1 от 27.08.2014, 09:42
=ЕСЛИ(ИЛИ(B1=A1*1,1;B1=A1*0,9);"NG";"OK")
А может быть так
=ЕСЛИ(ИЛИ(B1=A1*1,1;B1=A1*0,9;A1=B1*1,1;A1=B1*0,9);"NG";"OK")
P.S. Теория действительна всюду,в т.ч. и в Excel ;)

zs

Цитата: _Boroda_ от 27.08.2014, 10:04
=ЕСЛИ(ABS(B1/A1-1)<10%;"OK";"NG")
А может так:
=ЕСЛИ(ИЛИ(B1/A1=0,9;A1/B1=0,9;B1/A1=1,1;A1/B1=1,1);"NG";"OK")
С уважением, ZS5

vikttur

По следам последней формулы:
=ЕСЛИ(ИЛИ(B1/A1={0,9;1};A1/B1={0,9;1,1});"NG";"OK")

vikttur

Пара знаков потерялась:=ЕСЛИ(ИЛИ(B1/A1={0,9;1,1};A1/B1={0,9;1,1});"NG";"OK")

zs

Или последняя формула:
=ЕСЛИ(ИЛИ(B1/A1={0,9;1,1};СТЕПЕНЬ(B1/A1;-1)={0,9;1,1});"NG";"OK")