Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Сумма с условием

Автор melomory, 27.08.2014, 13:30

« назад - далее »

melomory

Здравствуйте!
Задача такая.
Есть столбец со значениями (количество ячеек = k). Необходимо получить первую сумму ячеек (от 1 до m) и вторую сумму (от k до j) [m,j<k], которые будут не больше n % от общей суммы ячеек (k).

melomory

файл с примером "как должно быть" :)

_Boroda_

#2
Так нужно?
=МАКС(ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(A$1;;;СТРОКА(A$1:A$21)))<=D2;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(A$1;;;СТРОКА(A$1:A$21)))))
и
=МАКС(ЕСЛИ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(A$21;;;-СТРОКА(A$1:A$21)))<=D2;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(A$21;;;-СТРОКА(A$1:A$21)))))

Обратите внимание: в справке для СМЕЩ написано "Высота (число строк) возвращаемой ссылки. Значение аргумента "высота" должно быть положительным числом" - Вас обманывают! Доказательство - отрицательный аргумент -СТРОКА(A$1:A$21) во второй формуле.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

melomory

Вроде должно получаться, но формула возвращает ответ 1 ???

melomory

Прошу прощения, немного поторопился и не обратил внимание на то, что там формула массива. Большое спасибо, все работает! :)

zs

=СУММ(B8:ИНДЕКС(B8:B15;(СЧЁТ(B8:B15)*F8)/100)), где B8-начало массива, F8-% суммирования.