Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Счётесли с несколькими условиями!!! Хелп!

Автор Nibiru Sajdisko, 29.08.2014, 09:40

« назад - далее »

Nibiru Sajdisko

Доброго времени суток дорогие эксперты!
Помогите!!!
необходимо написать функцию по подсчету чтобы отдельно считалось на критерии ОП вина А и отдельно М, и на критерии e-net вина А и отдельно М, по столба всего по вине "А" считается по функции счетесли. как прописать чтобы также считалась при наличии нескольких критериев. Выделены желтым.

vikttur

Excel-2003 или возможен более молодой? Покажите в примере желаемый результат.
Зачем листы 1 и 2? Чтобы больше запутать помогающих?

cheshiki1

вариант
=СУММПРОИЗВ(('1'!H2:H13=Итог!G3)*('1'!I2:I13=Итог!I4))

Nibiru Sajdisko

Цитата: vikttur от 29.08.2014, 10:12
Excel-2003 или возможен более молодой? Покажите в примере желаемый результат.
Зачем листы 1 и 2? Чтобы больше запутать помогающих?

С листов 1 и  2 берутся данные в итог. номер листа соответствует дате на итоговом листе

Excel 2007


Serge 007

=СУММПРОИЗВ((ДВССЫЛ(ДЕНЬ($A5)&"!h2:h13")=G$3)*(ДВССЫЛ(ДЕНЬ($A5)&"!i2:i13")=I$4))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Nibiru Sajdisko

СПАСИБО!!!!! :) :) :) :)

=СУММПРОИЗВ((ДВССЫЛ(ДЕНЬ($A5)&"!h2:h13")=G$3)*(ДВССЫЛ(ДЕНЬ($A5)&"!i2:i13")=I$4))

Вопрос, как преобразовать формулу, чтобы читалась в Excel 2003.
В настоящее время вместо значения пишет "#ЧИСЛО"

Pelena

Формула должна работать в 2003, проверьте данные в ячейках, на которые она ссылается

Nibiru Sajdisko

Цитата: Pelena от 05.09.2014, 09:36
Формула должна работать в 2003, проверьте данные в ячейках, на которые она ссылается

в 2007 видно и высчитывает ,  в 2003 нет :( :( :(

Pelena

Не надо использовать в формуле ссылки на столбцы целиком. Введите диапазоны, можно с запасом I1:I10000, например

Nibiru Sajdisko

Цитата: Pelena от 05.09.2014, 12:23
Не надо использовать в формуле ссылки на столбцы целиком. Введите диапазоны, можно с запасом I1:I10000, например

СПАСИБО!!!!!!!!!!!!!!!