Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

=СУММЕСЛИ() с критерием НЕ ПУСТО.

Автор Shadowmaker, 03.09.2014, 12:31

« назад - далее »

Shadowmaker

прошу помощи по формуле СУММЕСЛИ()
Есть 2 столбика А и В: в А числовые значения - в В разные данные. Необходимо в ячейке С1 сложить все значения из столбика А, напротив которых в столбике В есть непустые ячейки.

Как должна выглядеть эта формула. Если бы данные в В были всегда одинаковы - всё очевидно... =СУММЕСЛИ(А:А;"данные";В:В) но эти самые данные всегда разные - а формулу =СУММЕСЛИ(А:А;<>"";В:В) эксель не принимает. Что делать?

vikttur

О названии темы из правил:
ЦитироватьТема должна отражать суть вопроса

zs

Здравствуйте, Shadowmaker
Цитата: Shadowmaker от 03.09.2014, 12:31
а формулу =СУММЕСЛИ(А:А;<>"";В:В) эксель не принимает. Что делать?
=СУММЕСЛИ(B1:B5;"<>*";A1:A5)
С уважением, ZS5

IKor

В формуле СУММЕСЛИ(), а также в ряде других формул допускается использовать символы "*" и "?" для создания подходящей маски (* = любая последовательность символов; ? = любой символ)
Т.к. пустые ячейки не содержат ни одного символа, то вам поможет формула
=СУММЕСЛИ(B:B;"*";A:A)

IKor

Пардон, пропустил ключевую частицу НЕ.
Отдавая должное лаконичности формулы предложенной ZS рискну предложить еще вариант
=СУММ(A:A)-СУММЕСЛИ(B:B;"*";A:A)

zs

Здравствуйте, IKor!
Цитата: IKor от 03.09.2014, 14:56
формулы предложенной ZS )
Разрешите уточнить, IKor. ZS5 )

Shadowmaker

Цитата: IKor от 03.09.2014, 14:56
...
У меня получилось что-то вроде СУММЕСЛИ() наоборот:
=СУММ($G$10:$G$1000)-СУММЕСЛИ(N$10:N$1000;"";$G$10:$G$1000)

Pelena

Вариант
=СУММЕСЛИ(B1:B5;"<>";A1:A5)

ShAM

#8
Ребята, помогаете нарушителям! Поправил название темы, как смог.
У меня до варианта Елены было:
=СУММЕСЛИ(B1:B5;"<>"&"";A1:A5)
А вариант от ZS5 у меня игнорирует пустые ячейки.

Pelena

Алишер, прошу прощения, больше не повторится)

zs

Формула =СУММЕСЛИ(B1:B5;"<>*";A1:A5)
была к теме СУММЕСЛИ(
Мне показалось, она звучала так)
прошу помощи по формуле СУММЕСЛИ()
Есть 2 столбика А и В: в А числовые значения - в В разные данные. Необходимо в ячейке С1 сложить все значения из столбика А, напротив которых в столбике В есть ПУСТЫЕ ячейки

Как должна выглядеть эта формула. Если бы данные в В были всегда одинаковы - всё очевидно... =СУММЕСЛИ(А:А;"данные";В:В) но эти самые данные всегда разные - а формулу =СУММЕСЛИ(А:А;<>"";В:В) эксель не принимает. Что делать?
Ну а если наоборот, то мне опять же кажется, подойдет формула

=СУММЕСЛИ(B1:B5;">?";A1:A5)
С уважением, ZS5

vikttur

Да, тема звучала так, но это название функции, но никак не название темы, отражающее суть вопроса.
Цитироватьсложить все значения из столбика А, напротив которых в столбике В есть ПУСТЫЕ ячейки
=СУММЕСЛИ(B:B;"=";A:A)

zs

Здравствуйте, vikttur!
Всякая экономика сводится к экономии ресурсов.
У Вас формула эффективней на 5 знаков. Respect, vikttur!
P.S. Но суть вопрос тажа ;)

vikttur

Я отвечал на вопрос. Значит, не понял, в чем этот вопрос состоит.
Нужно "как наоборот"? Т.е. ненулевые? Или не пустые?

ShAM

У ТС было "непустые":
Цитата: Shadowmaker от 03.09.2014, 12:31Есть 2 столбика А и В: в А числовые значения - в В разные данные. Необходимо в ячейке С1 сложить все значения из столбика А, напротив которых в столбике В есть непустые ячейки.
У ZS5 стало "ПУСТЫЕ":
Цитата: zs от 04.09.2014, 10:01Есть 2 столбика А и В: в А числовые значения - в В разные данные. Необходимо в ячейке С1 сложить все значения из столбика А, напротив которых в столбике В есть ПУСТЫЕ ячейки
Но, по-моему, разобрали оба варианта :)