Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

поиск значения удовлетворяющего условию

Автор jore, 03.09.2014, 16:32

« назад - далее »

jore

Добрый день!
Помогите, пожалуйста!!
Формула = если в столбце J есть значение равное значению I25 (в нашем случае 14), то соответствуещее значение столбца K ( нашем случае 3) надо уменьшить на 10

cheshiki1

=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(I25;J15:J24;0));ИНДЕКС(K15:K24;ПОИСКПОЗ(I25;J15:J24;0))*10;"")

jore

благодарю за ответ!!!!!
помогите, пожалуйста, если не сложно, еще малость!
В идеале хотелось бы чтобы работало так:
1. если в столбце J (в нашем случае число 14) встречается 2 раза, то в формуле учитывается J22 (т.е.самое нижнее)
2. в формуле вычиталось не 10 (ячейка I9), а число строк между I25 и J22 (в данном случае 25-22=3)

vikttur

Нечеткие условия.
Строка 25 - всегда или последняя в диапазоне чисел?
"число 14 встречается 2 раза" - а если три? Если один?
Для варианта, когда искать последнюю строку с любым числом и последнюю строку с искомым числом:
=ЕСЛИ(СЧЁТЕСЛИ(J15:J25;I25);ПРОСМОТР(9E+307;J15:J50;СТРОКА(J15:J50))-ПРОСМОТР(2;1/(J15:J50=I25);СТРОКА(J15:J50));"")
Вариант предыдущей:
=ЕСЛИ(СЧЁТЕСЛИ(J15:J24;I25);ВПР(I25;J15:K24;2;)-10;"")

jore

Цитата: vikttur от 03.09.2014, 23:52

Строка 25 - всегда или последняя в диапазоне чисел?
нет, не последняя в диапозоне
Цитировать
"число 14 встречается 2 раза" - а если три? Если один?
число 14 (например) может встречаться много раз, а нужно брать в расчет самое нижнее в столбце

jore

Спасибо все работает отлично!
как подправить формулу, чтобы поиск работал при условии что в ячейке I25 например число 14,5, т.е. >= чем 14, но меньше чем значение в ячейке I23

vikttur

Вы условия порционно выдаете. Да и те, что показываете, урезанные.
Цитировать[строка 25] нет, не последняя в диапозоне
А какая? Какой критерий для определения строки? Или всегда 25?
Формула с поправкой:
=ЕСЛИ(СЧЁТЕСЛИ(J15:J25;I25);25-ПРОСМОТР(2;1/(J15:J50=I25);СТРОКА(J15:J50));"")
Последнее условие не понял.

Можете описать задачу в целом, а не скармливать по мелкой дозе?

jore

иногда написав все требуемые условия сразу никто не берется помочь!
благодарю Вас за Ваши ответы!

должно быть так -если число 14,5 то формула должна найти число 14 (т.е. 14,5>14 и 14,5<17)

vikttur

Цитироватьиногда написав все требуемые условия сразу никто не берется помочь
Это в случае, если не одна задача, а целое ТЗ. Или когда в описании задачи воды больше, чем полезной информации.

Я так и не понял, почему 17? В предыдущем сообщении Вы писали о ячейке  I23, теперь сравниваете с ячейкой диапазона...

jore

в файле который приложен число 17 в ячейке I22.

vikttur

В файле, который приложен, эта ячейка пуста!
Нужна J22? Но почему именно эта? Я уже несколько сообщений добиваюсь от Вас ответа - критерии определения нужной ячейки? Сейчас Вам нужна эта, потом скажете, что другая...

jore

извините, действительно опечатка- J22 нужная.
в файле пояснения

vikttur

Надо начинать дорабатывать то, что работает :)
=ЕСЛИ(F3=0;0;ЕСЛИ(ABS(G2<10);G2;-$B$1))
ABS(G2<10) - условие G2<10 покажет ЛОЖЬ или ИСТИНА, зачем ABS?
В условии число 10, в значении ссылка на В1. Почему разное?

vikttur

Чтобы и дальше не разбираться в работе формулы, опишите задачу столбца G.

jore

Цитата: vikttur от 04.09.2014, 13:30

В условии число 10, в значении ссылка на В1. Почему разное?

надо B1. число 10 всегда можно поменять на B1- главное чтобы работала формула