Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

поиск значения удовлетворяющего условию

Автор jore, 03.09.2014, 16:32

« назад - далее »

vikttur

Да что же такое?! Вы все читаете, что Вам пишут?
ЦитироватьЧтобы и дальше не разбираться в работе формулы, опишите задачу столбца G.
Чтобы помочь Вам, из Вас же приходится... клещами, как на допросе.
Можно тупо дать формулу, которая опирается на данные столбца G. Но ведь исходную формулу можно поменять, упростить! Я уже написал часть (по поводу ABS). А Вы в ответ - как партизан на допросе.
Вам решение нужно или так, поболтать зашли?
Вы ответите на поставленные ранее вопросы? Нет - значит нет. Ждите других помогающих.

jore

Цитата: vikttur от 04.09.2014, 13:30
Надо начинать дорабатывать то, что работает :)
=ЕСЛИ(F3=0;0;ЕСЛИ(ABS(G2<10);G2;-$B$1))
ABS(G2<10) - условие G2<10 покажет ЛОЖЬ или ИСТИНА, зачем ABS?
В условии число 10, в значении ссылка на В1. Почему разное?

Если использовать
=ЕСЛИ(F3=0;0;ЕСЛИ(ABS(G2<10);G2;-$B$1))
то неправильно идет счет. В формулу которая в файле надо просто добавить условие 2 написанное в файле

vikttur

Вы человеческий язык понимаете? Я показал, что в Вашей формуле функция ABS совершенно бесполезна! В ответ - надо добавить, а то работает неправильно.
Спрашиваю, что Вы хотите получить в общем, а Вы как кукла заведенная - надо добавить...
Да не только добавлять - упрощать нужно имеющееся. И, возможно, получится проще и удобнее.

Вы будете себе помогать?

vikttur

Отставили в сторону формулу в G.
Вот по Вашим условиям:
=ЕСЛИ(G11<0;ЕСЛИ(E12<F11;G11);ЕСЛИ(E12<F11;-5))
Вопросы. Если я надоел, партизаньте дальше, придет кто-то другой с помощью.
Почему при положительном -5? откуда это число?
Если G11<0 и E12>=F11 - что в этом случае?
Если G11>0 и E12>=F11 - что в этом случае?
Если G11=0 - что в этом случае?

jore


jore

и Вы не надоели, просто я не совсем понимаю Вашу формулу может быть....
Согласно условиям Вашей формулы должны быть результаты - см. файл

jore

сама задача:
G считает сколько дней осталось, когда можно начать тратить накопленные баллы
сумма баллов указывается в столбце B (в нашем случае для простоты везде 1), соответствует определенной дате
в столбце E указываются суммы баллов потраченных
число потраченных баллов может быть больше накопленных (есть резерв! Это только часть таблицы, поэтому в данном случае модель упрощенная, чтобы не скидывать множество взаимосвязанных таблиц )
как только потратили баллы начинается отсчет дней B1 в течение которых баллы копятся

Формулу в столбце G я указала, только не все возможные случаи считает

Pelena

Рискну я тоже поучаствовать  :)
В файле вариант немного с другим подходом. При появлении в столбце Е сумма вычитается из первой же возможной строки, а дальше снова идёт накопление.
Используется доп. столбец

RAN


vikttur

А что? Вполне даже похоже... Я не о "гадалке" - о решении.
Автору: сообщения 19 и 21 должны были быть в самом начале.

jore

Цитата: Pelena от 05.09.2014, 13:24
Рискну я тоже поучаствовать  :)
В файле вариант немного с другим подходом. При появлении в столбце Е сумма вычитается из первой же возможной строки, а дальше снова идёт накопление.
Используется доп. столбец

Спасибо за участие!
Идея доп столбца интересна, но вот реализация способа не очень правильная :(

jore

Цитата: vikttur от 05.09.2014, 23:30
А что? Вполне даже похоже... Я не о "гадалке" - о решении.
Автору: сообщения 19 и 21 должны были быть в самом начале.


Я Вас поняла

Pelena

Вы всё-таки приглядитесь повнимательнее к решению. Число 3 первый раз появляется в ячейке F5, и тут же обнуляется, т.к. в столбце Е первым встречается число 3, при этом сразу же в Н5 появляется -10 и начинается обратный отсчёт. То, что Вы выделили жёлтым уже не учитывается, ведь сумма 3 уже отнялась от ячейки F5.

Дело в том, что тот алгоритм, который предлагаете Вы, на формулах не реализуем, так как в любом случае там будет циклическая ссылка

jore

Спасибо!!
разобралась, потом увидела Ваше сообщение  :)
пока еще тестирую Ваш вариант (немного не привычен)

jore

только в H5 не -10 должно быть, а 0, т.к. 3=3 (число гасится полностью)