Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Последовательность чисел

Автор Gleb, 16.09.2014, 16:49

« назад - далее »

Gleb

Добрый день, есть две разные последовательности чисел от 1 до 2000, в столбик, нужна формула выводящая из этих двух, две новые, первая это числа которых не было в  последовательности А, а есть в последовательности Б и второй столбик числа которые были в последовательности А, а нет в последовательности Б. Заранее благодарен, тому кто поможет.

cheshiki1

создайте небольшой пример так есть так хотелось бы получить и прикладывайте сюда.

vikttur

=НАИМЕНЬШИЙ(ЕСЛИ(A1:A200=B1:B200;A1:A200);СТРОКА(A1))
формула массива (Ctrl+Shift+Enter), вводится в одну ячейку, протягивается вниз.
Аналогично для другого столбца.
Формулы массива тяжелые. можно с помощью доп. столбца с формулой на основе функций ЕСЛИ(СЧЕТЕСЛИ...

Gleb

Вот два столбца, нужно вывести новые числа и пропавшие числа.

ShAM

Формула от Виктора, только наоборот :)
=НАИМЕНЬШИЙ(ЕСЛИ(A$1:A$188<>C$1:C$188;A$1:A$188);СТРОКА(A1))
и не забываем, что:
Цитата: vikttur от 16.09.2014, 17:01формула массива (Ctrl+Shift+Enter)

IKor

Если вдруг не требуется именно создавать новые столбцы, а достаточно лишь в существующих столбцах цветом выделить ячейки, значения которых отсутствуют в другом столбце, то можно использовать возможности Условного форматирования:
1. Выделить диапазон А2:А314
2. Выбрать условное_форматирование (меню главная) => Создать правило => использовать формулу...
3. В появившемся окне записать формулу
=СЧЁТЕСЛИ($C$1:$C$314;A1)<1
4. По кнопке формат установить желаемый стиль выделенного шрифта
5. Применить изменения

Для второго столбца повторить указанные действия с соответствующим образом измененной формулой
=СЧЁТЕСЛИ($A$1:$A$314;C1)<1

ВАЖНО: сохранять указанные абсолютные и относительные ссылки.

Gleb

Я наверное привел не очень удачный пример, числа не находятся друг против друга, как в этом файле.

vikttur

Два варианта: формула массива и с доп. столбцом.

Gleb

Цитата: IKor от 16.09.2014, 18:27
Если вдруг не требуется именно создавать новые столбцы, а достаточно лишь в существующих столбцах цветом выделить ячейки, значения которых отсутствуют в другом столбце, то можно использовать возможности Условного форматирования:
1. Выделить диапазон А2:А314
2. Выбрать условное_форматирование (меню главная) => Создать правило => использовать формулу...
3. В появившемся окне записать формулу
=СЧЁТЕСЛИ($C$1:$C$314;A1)<1
4. По кнопке формат установить желаемый стиль выделенного шрифта
5. Применить изменения

Для второго столбца повторить указанные действия с соответствующим образом измененной формулой
=СЧЁТЕСЛИ($A$1:$A$314;C1)<1

ВАЖНО: сохранять указанные абсолютные и относительные ссылки.

Всем спасибо, этот вариант с выделением цветом, подошел больше всего .