Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Перенос последней заполненной ячейки в итоговую

Автор Эдуард Пашков, 20.09.2014, 17:25

« назад - далее »

Эдуард Пашков

Всем привет!

Собственно в теме все сказано, это нужно делать в файле экселя (2010 год).

vikttur


zs

формула по заполненным ячейкам различными форматами
=ДВССЫЛ(АДРЕС(СЧЁТЗ(A1:A100);1))

zs

формула массива для последних из заполненных различными форматами
=ИНДЕКС(A2:A20;МАКС(ЕСЛИ(A2:A20<>0;СТРОКА(A2:A20)-1)))

vikttur

zs, конструкция ДВССЫЛ(АДРЕС(... очень непрактична: одна функция летуча и "недоделана", вторая текстовая (а текстовые медленные). Если можно обходиться без этого - лучше обходиться.

vikttur

Для определения последнего значения в столбце (числовое или текстовое):
=ПРОСМОТР(2;1/(A1:A16<>"");A1:A16)

Эдуард Пашков

Господа, ваши ответы все очень хороши, наверно, просто я только начинающий юзер excel, поэтому мне можно пожалуйста поподробнее (если не сложно то со скринами), и если можно то код на англ, потому что у меня английская версия.

Премного благодарен!

vikttur

Ну да, Вам киношку еще заснять...
Пока все тут дружно кинулись Вам пример Вашей задачи в Excel рисовать, справку по функциям можно полистать...

zs

vikttur, а можно последнюю Вашу формулу модифицировать так, чтобы ориентироваться работа только по числам ;)

vikttur

См. ответ №1.
Если еще будут вопросы, внимательно см. ответ №7

zs