Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Подсчёт количества одного повторяющегося слова в диапазоне строк

Автор Максим Федин, 21.09.2014, 17:59

« назад - далее »

Максим Федин

День добрый!
Подскажите, пожалуйста решение.
Делаю расписание для кафедры ВУЗа. 1 день - 3 ячейки по вертикали, т.е. всего - 3 Строки на одну группу. На группе могут быть разные преподаватели, а их имена обозначаем сокращениями (например, "Ко", "Ло"....) И всё это забивается вперемешку.
Задача: Как подсчитать количество конкретного сокращения в этих 3 строках (чтобы узнать сколько дней будет отработано конкретным преподавателем)?
Пример прилагаю.
Спасибо!

vikttur



zs

Можно формулу,
СУММПРОИЗВ(D3:Y3*((D4:Y8)=AA1)) если у всех по одному занятию в день,
но лучше над каждым видом занятий добавил строку с количеством проведенных часов и тогда формула
=СУММПРОИЗВ(D3:Y3*((D4:Y4)=AA1)+D5:Y5*((D6:Y6)=AA1)+D7:Y7*((D8:Y8)=AA1))
С уважением, ZS5