Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

сделать выборку данных по указанному числу

Автор 0mega, 30.09.2014, 11:18

« назад - далее »

0mega

Всем доброго времени суток.
2003
sub no

Дано
Бухгалтерский документ имеет 12 Листов (по месяцам)+ 1"Общий"
Все Листы идентичны и отличаются только названием
Поскольку все названия Листов соответствуют своему месяцу, поэтому в качестве даты внутри Листа ставится только число, месяц берется с названия Листа, а год общий для всей книги прописан в  ячейке В1 на каждом Листе.
(Прекрасно понимаю что это идиотизм, но это уже факт)
Хочу
Лист "Общий".
При вводе Даты и кода операции - машина должна найти эту дату на соответствующем Листе  и заполнить все  ячейки.
P.S.
Кроме того что название месяца указано на Листе, есть еще одна кака. Юзер вводит число в формате 28/2 ( 28 февраля) .
Естественно машина автоматически прописывает настоящий год (28.02.2014) Но документ может быть датирован ЛЮБЫМ годом .
P.P.S
допускается построение дополнительных столбцов


cheshiki1

это?
=ВПР($C5;ВЫБОР(МЕСЯЦ($B5);Январь!$C$4:$H$8;Февраль!$C$4:$H$8;Март!$C$4:$H$8;Апрель!$C$4:$H$8;Май!$C$4:$H$8);2;)

0mega

cheshiki1
Спасибо, отличное решение!
Совсем небольшая коррекция

=...Май!$C$4:$H$8);СТОЛБЕЦ()-2;)
и формула имеет рабочий вид