Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Подсчет значений "2\6"из строки

Автор Андрей Рожков, 07.10.2014, 16:13

« назад - далее »

Андрей Рожков

Здравствуйте друзья.
Есть таблица с различными значениями, например: 8; 8,5; О, Б, 2\6 и просто пустыми полями.
Помогите пожалуйста, как из этих значений посчитать только те, что имеют вид "x1\x2", с такими условиями, что все x1 считаются отдельно, а все x2 отдельно.

cheshiki1

приложите пример так есть так хотелось бы получить.

vikttur

Опять табель рабочего времени? :)
Формулы массива (ввод Ctrl+Shift+Enter):
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("/";A1:A10));ЛЕВБ(A1:A10;ПОИСК("/";A1:A10)-1)))
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("/";A1:A10));ПСТР(A1:A10;ПОИСК("/";A1:A10)+1;5)))

В зависимости от данных формулы могут быть проще.

zs

Здравствуйте, vikttur. Может вопрос состоял в том, чтобы вид был  "как из этих значений посчитать только те, что имеют вид "x1\x2", т.е. формулы объединить &

ShAM

Цитата: zs от 07.10.2014, 18:26Может вопрос состоял в том, чтобы вид был  "как из этих значений посчитать только те, что имеют вид "x1\x2", т.е. формулы объединить &
Будет файл - будем поглядеть.

IKor

Если требуется посчитать количество ячеек, содержащих символ "\", то можно использовать функцию =СЧЁТЕСЛИ(A1:A11;"*\*")

Андрей Рожков

Цитата: vikttur от 07.10.2014, 16:33
Опять табель рабочего времени? :)
Формулы массива (ввод Ctrl+Shift+Enter):
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("/";A1:A10));ЛЕВБ(A1:A10;ПОИСК("/";A1:A10)-1)))
=СУММ(--ЕСЛИ(ЕЧИСЛО(ПОИСК("/";A1:A10));ПСТР(A1:A10;ПОИСК("/";A1:A10)+1;5)))

В зависимости от данных формулы могут быть проще.
Всем спасибо огромное, именно табель рабочего времени :)

Андрей Рожков

Только что то не считает по вашей формуле.

Андрей Рожков

Формула получилась такая для ячейки, =ЕСЛИОШИБКА(ЕСЛИ(ПОИСК("\";RC[-41]);ПРАВСИМВ(RC[-41];1);0);0)
Как посчитать диапазон?

vikttur

Нужна проверка на ошибку. Если нет знака, функция покажет ошибку:
ПОИСК("\";AB9)

vikttur

Цитироватьне считает по вашей формуле.
Это не моя :)
В моей ЕЧИСЛО.
ЦитироватьКак посчитать диапазон
Моя диапазон считает.

zs

Формулы Массива (ячейка формулы,F2(изм.диап),Ctrl-Shift-Enter)
=СУММПРОИЗВ(ЕСЛИ(ЕОШ(ПСТР($A$1:$A$3;1;НАЙТИ("/";$A$1:$A$3)-1));0;ПСТР($A$1:$A$3;1;НАЙТИ("/";$A$1:$A$3)-1)*1))
=СУММПРОИЗВ(ЕСЛИ(ЕОШ(ПРАВСИМВ($A$1:$A$3;ДЛСТР($A$1:$A$3)-НАЙТИ("/";$A$1:$A$3)));0;(ПРАВСИМВ($A$1:$A$3;ДЛСТР($A$1:$A$3)-НАЙТИ("/";$A$1:$A$3)))*1))