Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

суммирование числовых значений при неполном совпадении артикула

Автор Соня13, 09.10.2014, 17:31

« назад - далее »

Соня13

Добрый день.
Честно говоря даже не знаю как правильно назвать тему, т.к. без примера не объяснить, что конкретно нужно.
Имеем - большой файл прайса, в котором содержатся № артикулов, цена. но у некоторых артикулов есть доп.стоимость, которая обозначается текстовой приставкой к номеру артикула.
Нужно - формула для подстановки этой доп.стоимости в стоимость самого артикула.

вложила файл, в котором должно быть наглядно понятно, что имеем и что нужно

cheshiki1

вариант
=ЕСЛИ(ЕОШ(ПОИСК("_";A3));ИНДЕКС($B$3:$B$12;СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(A3&"_";$A$3:$A$12))*СТРОКА($A$1:$A$10)));0)

vikttur


Соня13