Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

вычитание значений, записанных с буквами

Автор MyTHblu, 17.11.2014, 12:18

« назад - далее »

MyTHblu

День добрый, задача.... есть значения(буквы и цифры) в ячейки 1 и в ячейке 2, в 3-ей ячейке нужно получить разницу 1-ой и 2-ой, но не арифметически, а простом методом исключения тех что были во 2-ой

zs

=СЖПРОБЕЛЫ(ПОДСТАВИТЬ(A1;B1;""))

vikttur

Может ли быть вариант, когда точного соответствия нет?
Например: 1а;4b;3c - 1b; = 1а;3b;3c

IKor

Как вариант:
=ЕСЛИОШИБКА(формула;исходное_значение)

Сложнее для ситуации, когда требуется анализировать не полное, а частичное соответствие:
Например: 1а;4b;3c - 1b;3с = 1а;3b