Приобразования числа в месяц

Автор Twilight Life, 20.11.2014, 21:26

« назад - далее »

Twilight Life

Такой вопрос.
С GA вытянул масив данных о каналах трафика. Там три столбца, первый - название канала, второй - номер месяца, третий - количество сеансов.
Строк выходит довольно много, около 200. Для более удобного работы с данной таблицей необходимо второй столбец с номером числа (05, 06, 01, 03 ...) преобразовать в название месяца.
Обычной заменой формата данных на "Дата" - не получается, т.к. excel видит на первом месте день, а только потом месяц. Т.е. необходимо сделать так, чтобы отсчет начинался сразу с месяцев.
Подскажите пожалуйста как сделать.

gling

#1
Можно такой формулой в доп столбце =ТЕКСТ("1."&B3;"ММММ")или так =ДАТА(;B3;1)В3 ячейка с месяцем
Цитироватьвторой столбец с номером числа (05, 06, 01, 03 ...)
Во втором случае формат ячейки "Дата"
mail: vovik100661@gmail.com;
ЯД-41001506838083.

Twilight Life

Благодарю!!! Вот этот вариант выбрал:
=ДАТА(;B3;1)
Просто, и без лишних изысканий.

Сам пришел к немного более долгому способу. В одной ячейке ввел - "1."  во второй - ".14". Назовем эти ячейки С54 и С55.
Затем создал столбец с функцией =ЗНАЧЕН($С$54&(номер_ячейки_месяца)&$C$55)

gling

Все правильно Вашу формулу можно еще записать так:=ЗНАЧЕН("01."&(C6)&".2014")
=ЗНАЧЕН("01."&(C6)&".2014")
=--("01."&(C6)&".2014")
=--("01."&(C6))
=--("1."&(C6))
чтобы не задействовать лишние ячейки, С6 ячейка с месяцем.
mail: vovik100661@gmail.com;
ЯД-41001506838083.