Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

количество положительных попаданий в интервал

Автор zolotnik, 26.11.2014, 15:51

« назад - далее »

zolotnik

помогите посчитать количество положительных  ячеек в столбце В ,для кажлого интервала в столбцеE

cheshiki1

#1
=СУММПРОИЗВ((ВРЕМЗНАЧ(ПСТР(E3;1;ПОИСК("-";E3)-1)&":00")<$A$3:$A$34)*($A$3:$A$34<=ВРЕМЗНАЧ(ПСТР(E3;ПОИСК("-";E3)+1;9)&":00"))*($B$3:$B$34>0))
вашу формулу можно чуть укоротить
=ВРЕМЗНАЧ(ТЕКСТ(Лист2!A3;"ч:мм:сс"))

zolotnik

спасибо большое! и за укороченную формулу тоже :)

vikttur

Намного проще, если задавать не интервал, а только начало

zolotnik

Цитата: vikttur от 26.11.2014, 22:30
Намного проще, если задавать не интервал, а только начало
ток сечас заметил что можно менять карму. спаибо!

vikttur

Дело не в карме, а в реакции на ответы в своей теме.