Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Вопрос по созданию таблицы.

Автор Владимир Иванов, 25.02.2015, 21:00

« назад - далее »

Владимир Иванов

Добрый вечер!
Уважаемые специалисты, помогите пожалуйста разработать таблицу.
Составляем для своих клиентов акты оказания медицинских услуг, вписывая в них произведенную работу и стоимость (пример во вложении). Общее кол-во медицинских услуг - более 100 и к каждой услуге присвоен порядковый номер (1, 2, 3, 4 и т.д...) и стоимость. Каждый раз при составлении акта приходится копировать информацию из прайс-листа, что не очень удобно и занимает много времени. Возможно ли в Excel разработать таблицу, чтобы в первом столбце "Код услуги" я вписывал номер услуги от 1 до 100, во втором столбце - "Наименование услуги", автоматически подставлялось описание и в пятом столбце отобразилась "цена" данной услуги? Как создать такую привязку "код услуги" + "наименованию" + "цена"? Буду очень признателен за помощь.
Заранее спасибо!

Владимир Иванов

Прайс-лист для примера

vikttur

Можно.
Таблицу прайса разместить в Excel. Подтягивать данные с помощью функции ВПР или связки ИНДЕКС/ПОИСКПОЗ

Владимир Иванов

#3
Vikttur, можете на примере показать как это сделать? Я, с программой Excel на "Вы"  :).
Спасибо!

vikttur

ЦитироватьТаблицу прайса разместить в Excel
А дальше будем помогать

Владимир Иванов

#5
Без горе-цитаты хуже? [МОДЕРАТОР]
Готово!

vikttur

Ctrl+F3 - именованный диапазон.
Правильнее сделать два диапазона: один с разделами, другой - подчиненный, с услугами. Как сделать? ищите Связанные выпадающие списки.
Например, здесь http://www.planetaexcel.ru/techniques/1/

Владимир Иванов

Добрый день, vikttur!

Большое спасибо за пример и ссылку на обучающие уроки. Нашел для себя много полезной информации.
Вот что у меня получилось в итоге, используя вашу формулу.

Владимир Иванов

Vikttur, отдельное Вам спасибо за оперативную помощь!

vikttur

ИТОГО не учитывает строку 13. Для расширяемой таблицы (при вставке строк):
=СУММ(F6:ИНДЕКС(F1:F15;СТРОКА(F15)-2))*(1-F14)

Если вывести в отдельный список коды услуг, выпадающий список можно сделать без лишних строк.

Владимир Иванов

Подкорректировал!

Vikttur, я столкнулся еще с одной ошибкой. Когда выставляю коды 6 либо 7, в ячейках "цена" и "сумма" появляется #ЗНАЧ!
При сокращении кол-ва слов в описании услуги (в прайсе), ошибка пропадает и выставляется цена. Подскажите пожалуйста в чем дело. Спасибо! 

vikttur

#11
Для ВПР критична длина текста: не более 255 знаков.
Ищите не название услуги. а тот же код:
=ЕСЛИ(B9="";"";ВПР(A9;Прайс!$A$2:$C$161;3;))

Владимир Иванов

Понял, буду знать. Сейчас попробую исправить ошибку.

Низкий поклон за помощь!