Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Определение высокосного года

Автор Олег Ред, 16.03.2015, 16:24

« назад - далее »

MCH

zs, так и не понял, зачем из B1 нужно вычетать A1?
чем выражение ОСТАТ(B1/400;1)=0 лучше, чем ОСТАТ(B1;400)=0? как минимум второе короче
Почему нужно выдумывать новые, более длинные формулы, если уже даны ответы работающими формулами?

Если хочется високосность текстом писать, то можно использовать формулу:
=ЕСЛИ(СУММ((ОСТАТ(A1;{4;100;400})=0)*{1;-1;1});"Да";"Нет")
где в A1 указан год

zs


ShAM


zs