суммирование по нескольким критериям

Автор Jim, 14.04.2015, 17:13

« назад - далее »

Jim

всем привет!

заранее извиняюсь, понимаю что такая тема была, но конкретно к задаче не смог подставить формулы.

необходимо посчитать сумму по нескольким критериям без дополнительных столбцов и без дополнительных формул. всё решение необходимо одной формулой.

см пример во вложении.

vikttur

=СУММЕСЛИ(A2:A6;G2;B2:B6)+СУММЕСЛИ(A2:A6;G3;B2:B6)
формула массива:
=СУММ(ЕСЛИ(A2:A6=ТРАНСП(G2:G3);B2:B6))

Czeslaw

Мне кажется, что можно применить и такую формулу:
=SUMPRODUCT(((A2:A6=G2)+(A2:A6=G3))*B2:B6)

vikttur

Если для 2-3 значений, лучше несколько СУММЕСЛИ, формула легче в вычислениях.
Если значений много, советую возле каждого из них СУММЕСЛИ, и итоговая - обычная СУММ. Не стоит отвергать доп. столбцы/строки. Их можно спрятать, но доп. формулы во многих случаях намного облегчают вычисления.