Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Как правильно составиться формулу с несколькими условиями

Автор Александр Бойков, 27.04.2015, 22:51

« назад - далее »

Александр Бойков

нужно что бы было что то вроде этого
=ЕСЛИ(ИЛИ(A3=1;);"2";"");ЕСЛИ(ИЛИ(А4=1;);"1";"");ЕСЛИ(ИЛИ(А5=1;);"0";"")

задача такая есть таблица, в неё должно прописаться или 2 или 1 или 0 в зависимости от того в какой клетке поставишь "1" если в A3 то показывать будет 2, если в A4 то показывать будет 1, если в A5 то показывать будет 0

vikttur

=ЕСЛИ(A3=1;2;ЕСЛИ(А4=1;1;ЕСЛИ(А5=1;0;"")))
=3-ПОИСКПОЗ(1;А3:А5;)

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Александр Бойков

#3
Цитировать=ЕСЛИ(A3=1;2;ЕСЛИ(А4=1;1;ЕСЛИ(А5=1;0;"")))
это не работает   если 2 выдает нормально то если в  А4 или А5 прописать  1 то пишет "#имя?"
а =3-ПОИСКПОЗ(1;А3:А5;)    мне же значение нужны не ТАМ где пишут "1" там то проблем не было а нужно что бы показывало ЗНАЧЕНИЕ результата формулы тобишь есть формула =ЕСЛИ(ИЛИ(A3=1;);"2";"")   например этот результат выводиться в ячейку L3  и в ячейке есть результат "2" но он там выражен ФОРМУЛОЙ, и реально этих 2 там нету и если я  направлю на ячейку L3 другую формулу то она НЕВИДИТ результата и пишет 0 а не 2....

Цитата: Serge 007 от 27.04.2015, 23:19
=СУММПРОИЗВ(A3:A5*{2:1:0})

а это формула не вообше ничем, так как как нужно что бы так как  как писал выше нужно что бы СКАЛАДЫВАЛО РЕЗУЛЬТАТ формулы....  и там только 1 ЗНАЧЕНИЕ будет а остальные в не или 2 или 1 или 0... а  не все сразу... если все сразу то она считает норм но если хоть 1 нету то то пишет "#знач!"

а если формулу =СУММПРОИЗВ(L3:L5) то пишет ВСЕГДА 0.... в не то сумма что получена в результате формулы =ЕСЛИ(ИЛИ(A3=1;);"2";"") полученные

Serge 007

Цитата: Александр Бойков от 27.04.2015, 23:29
это не работает   если 2 выдает нормально то если в  А4 или А5 прописать  1 то пишет "#имя?"
Все три варианта рабочие
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Александр Бойков