Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Поиск совпадений в диапазоне

Автор Mailo, 12.06.2015, 21:37

« назад - далее »

Mailo

Помогите осуществить поиск совпадений по диапазону данных. Прикрепляю пример для наглядности))).
Спасибо

vikttur

Цитировать37,2   СМО-П 38-40
Почему? 37,2 не попадает ни в один из диапазонов.

Если только по нижней границе:
=ЕСЛИ(I4;ИНДЕКС($B$4:$B$13;ПОИСКПОЗ(I4;$D$4:$D$13));"")

Mailo

#2
Когда не попадает в диапазон, надо что бы ближайший больший выбирался, то есть для 37,2 подходит СМО-П 38-40

Цитирование - это не вставка целого сообщения[МОДЕРАТОР]

Czeslaw

А как быть со значениями, которые не попадают в указанные диапазоны?

vikttur

=ЕСЛИ(I4;ИНДЕКС($B$4:$B$13;ПОИСКПОЗ(I4;$E$4:$E$13)+1-СЧЁТЕСЛИ($E$4:$E$13;I4));"")

Mailo

Спасибо vikttur и Czeslaw. Все работает.

Czeslaw

В этом случае предлагаю переделать диапазоны и тогда решение будет выглядеть так.

vikttur

#7
Со вспомогательным столбцом:
=ЕСЛИОШИБКА(ВПР(J4;$A$4:$C$13;3);"")

Mailo

#8
vikttur,А можно, что бы при значении фактического диаметра больше чем в имеющихся диапазонах выдавалось сообщение, типа "нет такого". например если диаметр 72мм? Но только если значение очень большое(на 1 и больше), в противном случае ближайше. то есть для диаметра 50,9 должно выбирать СМО-П 48-50.

vikttur

Есть хорошая функция ЕСЛИ, почтайте о ней.
=ЕСЛИ(условие;формула;текст)