Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Как пронумеровать строки в Excel.

Автор Диана23, 22.06.2015, 23:14

« назад - далее »

Диана23

Дана таблица.
Иванов     23800 роза
Петров     18200 пион
Сидоров   15400 ромашка
Петров     18200 гвоздика
Еременко  78600 сирень
Васечкин  90800 ландыш
Сидоров   15400 ромашка
Иванов     25700 роза
Мишин     12800 лаванда


Нужно пронумеровать строки, но при этом строки, в которых все три столбца одинаковы оставить под одним номером.
Вот так, только это вручную.
1 Васечкин    90800 ландыш
2 Еременко    78600 сирень
3 Иванов       23800 роза
4 Иванов       25700 роза
5 Петров       18200 пион
6 Петров       18200 гвоздика
7 Сидоров      15400 ромашка
7 Сидоров      15400 ромашка
8 Мишин        12800 лаванда

vikttur

В первой строке "шапка" таблицы или (если без "шапки") для первого значения в столбце А поставить 1.
Для А2:
=ЕСЛИ(ПОИСКПОЗ(B2;$B$2:B2;)=СТРОКА(A1);МАКС($A$1:A1)+1;ИНДЕКС($A$1:A1;ПОИСКПОЗ(B2;$B$1:B2;)))

Диана23


IKor

На всякий случай приложу еще один вариант.

Судя по исходному сообщению темы автор не ограничивает нас в использовании инструментов Экселя: таких как сортировка.

В этом случае формула для нумерованного столбца существенно упрощается:
А1: 0
А2: =ЕСЛИ(И(B2=B1;C2=C1;D2=D1);A1;A1+1)
А3 и далее: скопировать формулу из А2

Диана23


zs

Со второй строки
=ЕСЛИ(СЧЁТЕСЛИ(B6:D6;B6)=3;ИНДЕКС(A3:A5;ПОИСКПОЗ(B6;B3:B5);1);МАКС(A3:A5)+1)