Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Копирование ячеек по условию

Автор Vyacheslav Zverev, 16.07.2015, 06:04

« назад - далее »

Vyacheslav Zverev

Есть лист1, в столбце 1 - ячейки с датами (одного месяца) в столбце 4 - суммы проплат и примечания, в столбце 5 текст примечания. На листе 2, со 2 столбца дни месяца. Нужно в столбец дня скопировать с листа 1 суммы с примечаниями по условию: если значение в 5 столбце = "текст1", то со 2 по 10 строку (их не больше 5), остальное с 11 строки

Serge 007

Не видя файла можно только посоветовать использовать функцию СУММЕСЛИ(), возможно в сочетании с другими функциями
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Vyacheslav Zverev

файл вложил. Но при чем тут сумм если. На листе приход - все приходы по счету с датами: Дата прихода, сумма прихода, и следующий столбец текст примечания суммы. Нужно в лист "приход по дням" скопировать, но с разноской: приходы от 01.06.2015 в столбец 2, от 02.06.2015 в стобец 3, и не проссумировать их а именно скопировать ячейки.

Serge 007

Цитата: Vyacheslav Zverev от 16.07.2015, 07:50файл вложил. На листе приход - все приходы по счету с датами
Нет в файле никаких дат и значений на листе приход за исключением шапки таблицы. Вы видимо файл перепутали

Цитата: Vyacheslav Zverev от 16.07.2015, 07:50Нужно в лист "приход по дням" скопировать, именно скопировать ячейки.
Копировать формулы не умеют, тут VBA нужен

Сделал просто возврат значений формулой массива с подавлением значений ошибки для xls:=ЕСЛИ(СЧЁТ(ЕСЛИ(B$1=Приход!$A$3:$A$10;СТРОКА($1:$8)))>=СТРОКА(A1);ИНДЕКС(Приход!$D$3:$D$10;НАИМЕНЬШИЙ(ЕСЛИ(B$1=Приход!$A$3:$A$10;СТРОКА($1:$8));СТРОКА(A1)));"")
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Vyacheslav Zverev

Ну я создавал тему в разделе VBA и именно макрос который это бы сделал меня и интересовал. Подправленного вида файл положил. (Несколько других макросы используемые для заполнения таблицы там уже есть)

Крайнов

#5
Vyacheslav Zverev, лови

Vyacheslav Zverev

Крайнов, спасибо большое. Был бы поблизости пива бы поставил )