Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Создание таблицы возможных сочетаний

Автор Timi, 26.08.2015, 18:38

« назад - далее »

Timi

Здравствуйте!
У меня есть две таблицы с уникальными значениями (а в дальнейшем и три).
В первой таблице n уникальных значений, во второй - m. Как получить таблицу с m x n уникальными сочетаниями?
Заранее спасибо.

Timi

Нашел хорошее решение с MOD().
Ещё есть варианты? )
VBA и SQL не предлагать. )

vikttur

Типа такого:
=ЕСЛИ(СТРОКА(A1)>$D$4;"";ИНДЕКС($A$2:$A$100;(СТРОКА(A1)-1)/$D$3+1))

MCH

=ИНДЕКС(PG[Prod. Group];(СТРОКА(A1)-1)/СЧЁТЗ(PA[PA])+1)
=ИНДЕКС(PA[PA];ОСТАТ(СТРОКА(A1)-1;СЧЁТЗ(PA[PA]))+1)

zs

=ЕСЛИ(G126=0;PG[[#Эта строка];[Prod. Group]];ЕСЛИ(СЧЁТЗ($H$2:H126)+1>=СЧЁТЗ($A$2:$A$15)*СЧЁТЗ($B$2:$B$10);"";ЛЕВСИМВ(G126;2)&СЧЁТЕСЛИ($H$1:H127;H127)))
=ЕСЛИ(B127>0;B127;ЕСЛИ(СЧЁТЗ($H$2:H126)+1<СЧЁТЗ($A$2:$A$15)*СЧЁТЗ($B$2:$B$10);ИНДЕКС($H$1:H126;СТРОКА()-СЧЁТЗ(PA[PA]));""))