Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Выборка дат

Автор Николай Измайлов, 02.09.2015, 23:18

« назад - далее »

Николай Измайлов

Доброго времени суток.
Помогите плз с формулой дат. Есть столбец с числами в формате dd.mm.yyyy  и есть ячейка в которой указан № месяца (например сентябрь - 9), как посчитать количество дат за определенный месяц, ссылаясь на эту ячейку например, если этих дат может быть сколь угодно в месяце?

Serge 007

Здравствуйте

=СУММПРОИЗВ(--(МЕСЯЦ(A1:A15)=C1))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

vikttur

=СЧЁТЕСЛИ(A1:A15;">="& ДАТА(2015;C1;1))-СЧЁТЕСЛИ(A1:A15;">"& КОНМЕСЯЦА(ДАТА(2015;C1;1);0))

Николай Измайлов

#3
vikttur, спасибо. Формула работает только если в столбце с датами есть первое число, ну и наверное последнее :))

vikttur

Наверное, сначала нужно проверить, а потом писать.

zs

Что нас подводит, ребята, это постоянные распри. Леопольд был прав: "Ребята, давайте жить дружно!"
Предлагаю решить этот вопрос по следующей 100% безошибочной формуле:
=СЧЁТЕСЛИМН(A1:A15;">="&ДАТАМЕС(ДАТА(2015;C1+1;1);-1);A1:A15;"<" &ДАТА(2015;C1+1;1))
С уважением, ZS5)

vikttur

zs, безошибочная формула повторяет формулу на СЧЕТЕСЛИ. Хорошая (даже лучше), но для 2003 не пойдет.

Serge 007

Цитата: vikttur от 03.09.2015, 18:16Хорошая (даже лучше)...
Не лучше. Но "тяжелее" и медленнее

Цитата: vikttur от 03.09.2015, 18:16...для 2003 не пойдет.
Виктор, КОНМЕСЯЦА() нет в 2003 Excel ;)
Она в пакете анализа
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

vikttur

ЦитироватьКОНМЕСЯЦА() нет в 2003 Excel
Прокол :)
Я уже забыл, давно без 2003.