Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Динамический список

Автор Timi, 07.09.2015, 11:02

« назад - далее »

Timi

Добрый день!

Еще одна головоломка.

Есть матрица: 2 поля по вертикали (Field 1 и Field 2) и одно - по горизонтали (Field 3).
Необходимо при выборе одного из столбцов (Field 3) возвращать список без пробелов поля 1 и поля 2, для которых значения в матрице не пустые.

VBA и _сводные_ таблицы не предлагать.

Заранее спасибо.

cheshiki1

если для одной таблицы, то вариант

IKor

Вот еще один вариант с дополнительным столбцом.
Он не привязан к исходной таблице, но требует обеспечить минимальную высоту дополнительного столбца не менее высоты исходной таблицы (он может быть расположен в стороне или даже на отдельном листе).

vikttur

#3
Доп. формула в столбец А
=ЕСЛИ(ИНДЕКС(Table1[@[Field 3.1]:[Field 3.5]];ПОИСКПОЗ($K$2;Table1[[#Заголовки];[Field 3.1]:[Field 3.5]];));МАКС($A$2:A2)+1)
=ЕСЛИ(ИНДЕКС(Sheet1!$D3:$H3;ПОИСКПОЗ($K$2;Sheet1!$D$2:$H$2;));МАКС($A$2:A2)+1)

Выборка возможна простой ВПР

Если результирующая таблица небольшая, то вариант - формула массива для выбора Field 1
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$B$12;НАИМЕНЬШИЙ(ЕСЛИ($D$2:$H$2=$K$2;ЕСЛИ($D$3:$H$12;СТРОКА($B$3:$B$12)-2));СТРОКА(A1)));"")
Field 2 - с помощью ВПР

IKor

Цитата: vikttur от 07.09.2015, 13:55
Выборка возможна простой ВПР
Но только с условием уникальности данных (отсутствие повторов значений) в первом столбце исходной таблицы - КМК, это сильное упрощение поля исходных данных...

vikttur

Вы неправы. Формула формирует диапазон уникальных целых чисел.

А вот во втором случае (приенение формулы массива) обязательным условием для применения ВПР является уникальность значений Field 1