Поиск одинакового числа в столбце данных.

Автор Яна Варзова, 14.09.2015, 13:23

« назад - далее »

Яна Варзова

Здравствуйте!

Подскажите, пожалуйста, как можно это сделать.

Дано:
1.Таблица, ее столбцы A B C D E
2.Данные по которым нужно искать, в столбцах J K

Задача:
1.Найти в столбце E таблицы такого же числа как в K2 до предела L2.
2.Далее, нужно выписать полностью строку в которой найдено число (в пределах K2 до L2).
3. В выписанных строках, оставить те строки, в которых значения в 3-ем столбце (этой строки) больше J2.
4. И, если возможно, то оставшиеся строки отсортировать по возрастанию - по значению последнего столбца – K2 и J2

vikttur

ЦитироватьВ выписанных строках, оставить те строки, в которых значения в 3-ем столбце (этой строки) больше J2.
Нет таких.
Формула нумерации нужных строк:
=ЕСЛИ(ЕЧИСЛО(ПОИСК($K$2;B3));ЕСЛИ(E3<=$L$2;ЕСЛИ(C3>$J$2;МАКС($F$2:F2)+1)))
С помощью ИНДЕКС/ПОИСКПОЗ и номера строки можно выбрать нужные строки.

У Вас не вопрос, а целое техзадание. Подсказка есть. Сами пробуйте.

vikttur

Как этот вопрос связан с темой? Только Вшей задачей? Извините, но это не причина.

Яна Варзова

#3
Не нужно извиняться! Легко создам новую. Хорошо что исправили!

Но я уже нашла очень простое решение этого вопроса, который для соблюдения порядка, удаляю.