Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Округление суммы

Автор Екатерина Комарова, 18.09.2015, 11:53

« назад - далее »

Екатерина Комарова

Добрый день! Округление з/п!!!!
Есть:
15630
15680
Необходимо округлить в одну из сторон до 100 рублей.
15600
15700
Как это сделать????? Заранее спасибо!!!!!

TimSha

"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

cheshiki1

=ОКРУГЛ(A1;-2)
ОКРУГЛТ в версиях 2007 и выше, в 2003 и ниже нет. ;)

vikttur

#3
=ОКРУГЛ(A1/100;0)*100

Дмитрий Езепов

#4
В теме уже дали два варианта ответа, но про округление довольно подробно можно здесь почитать http://statanaliz.info/excel/formuly/75-okruglenie-chisel-v-excel

zs

для всех версий
=ЦЕЛОЕ(ЕСЛИ((ЦЕЛОЕ(A5/100)+1-A5/100)*10<=5;A5/100+1;A5/100+0))*100

MCH

zs, зачем так сложно?
Достаточно:
=ЦЕЛОЕ(A1/100+0,5)*100

zs

Цитата: MCH от 23.09.2015, 23:36
zs, зачем так сложно?
сложное и подробное не синонимы

ShAM

Цитата: zs от 25.09.2015, 08:40сложное и подробное не синонимы
Тогда могли бы еще на пару строк подробнее написать.

zs

=ЦЕЛОЕ(ЕСЛИ((ЦЕЛОЕ(ЕСЛИ((ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)+1-ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)*10<=5;ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+1);ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+0))/10)+1-ЕСЛИ((ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)+1-ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)*10<=5;ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+1);ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+0))/10)*10<=5;ЕСЛИ((ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)+1-ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)*10<=5;ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+1);ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+0))/10+1;ЕСЛИ((ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)+1-ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10)*10<=5;ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+1);ЦЕЛОЕ(ЕСЛИ(--ПРАВСИМВ(A5;1)>=5;ЦЕЛОЕ(A5)+1;ЦЕЛОЕ(A5))/10+0))/10+0))*100
P.S.число десятичных знаков в А5-1