Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

поставить значение в соответствии с попаданием в интервал.

Автор Danya, 14.10.2015, 11:49

« назад - далее »

Danya

подскажите...
Есть несколько интервалов. Каждому интервалу соответствует определен-ное название и есть числа. Нужно присвоить числам название интервала, в зави-симости от того в какой интервал попало значение.
Пример прикрепляю с решением. Но думаю, что есть более простой и изящ-ный способ решения.

runner

Если интервалы подряд - поиграйте в ВПР с неточным соответствием.

Danya

Приложил файл к теме.

runner

В столбец D скопируйте столбец A.

В ячейку F3
=ВПР(E3;$B$3:$D$6;3;1)
и протяните вниз

Столбец C - уже не используется

Danya

#4
а почему мы не используем С столбец?

runner

Он не используется в формуле.
Диапазоны идут один за другим неразрывно, учитывается только начало диапазона с наименьшего значения.

Danya

#6
ок. А что обозначает 1 в конце формулы?

runner

А это как раз то самое "неточное соответствие" - подробности во встроенной в программу справке

Danya

#8
Цитата: runner от 14.10.2015, 12:45
Диапазоны идут один за другим неразрывно
а что если диапазоны будут с разрывами?Как быть в таком случае?

runner

Цитата: Danya от 14.10.2015, 13:03
а что если диапазоны будут с разрывами?Как быть в таком случае?

"... а если бы он вёз патроны?!" (c) :)

а откуда возьмётся что-то попадающее в разрывы?
Ведь диапазоны выстраиваются на основе имеющегося, как я понял. Пересекающихся диапазонов нет.

Правда, поиграйте формулой ВПР - сделайте столбец чисел от одного до ста, например. Рядом сделайте диапазон с пороговыми значениями, из той же сотни. Дайте названия значениям диапазона. Прогоните по "сотне" ВПР с неточным соответствием. Поймёте механизм - будете знать, что делать.



zs