Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Изменение вычислений по условию

Автор omon3, 21.11.2015, 23:39

« назад - далее »

omon3

Кратко суть проблемы вот в чем. Нужно создать условие ЕСЛИ, типа вот этого: =ЕСЛИ(C1>0;[B1*3+C1*4];[A1*3]), но ексель ругается и не хочет считать то что внутри так как ему нужно [значение_если_истина], а не выражение если истина. Что делать?

vikttur


omon3

#2
Спасибо

zs

Можно добавить одну ячейку и арифметики
=ЕСЛИ(C1>0;(B1*1+C1*(1+1/D1));(A1*1))*D1

vikttur

zs, зачем? Чтобы вычислений добавить? Так это нужно было ячеек 5-10 подключить к вычислениям :)

zs

#5
Исключение абсолютных цифр
Можно и упростить вычисления(используя 2 дополнительные ячейки), изменив расположение данных, сдвинув две цифры вниз