Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Как объединить товары с одинаковыми названиями в 1?

Автор lexedunut, 28.01.2016, 10:46

« назад - далее »

lexedunut

Всем привет! Есть .csv файл с большим списком товаров. Часть товаров сгруппированы друг за другом и отличаются одним полем (фактически это один и тот же товар, который имеет различные свойства).
ID  NAME    PRICE   DESC
3630     лодка Адмирал 280  80.0000 св 1
3630     лодка Адмирал 280  80.0000 св 2
3630     лодка Адмирал 280  80.0000 св 3

Как объединить такие товары в один, записав все различающиеся поля в одно вида: св 1;св 2;св 3 ?
ID  NAME    PRICE   DESC
3630     лодка Адмирал 280  80.0000 св 1;св 2;св 3

Пробую записать в столбце так =ЕСЛИ(A2=A1;B101894&"; "&X2;X2) и размножить на все строки, но получаю предупреждение о циклической ссылке.. Почему?

vikttur

Лень вбивать десяток строк данных...
Если Вам не лень, покажите, пожалуйста, пример.

lexedunut

#2
vikttur вот собственно пример: нужно объединить товары с одинаковыми названиями со слиянием параметров свойств поля X (ссылок на картинки) разделяемых друг от друга с помощью ";"

zs

#3
Как вариант(без ; )
=ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОВТОР(D1;СЧЁТЕСЛИ(A1:A3;A3));1;2;2);1;3;2)

lexedunut

#4
не нужно цитировать, если не нужно :)

zs Не совсем понимаю куда подставлять формулу.  Для свободной ячейки получаю:
IE_DETAIL_TEXTIE_DETAIL_TEXT.
Я правильно понимаю, что вы склейку строк предлагаете, а не просто объединение ячеек в 1  строку?

vikttur

Так ли нужно было выкладывать файл с 50-ю ненужными столбцами? Для того, чтобы помогающих запутывать?

В столбец С:
=ЕСЛИ(B2=B3;D2&";"&C3;D2)

lexedunut

#6
Второй раз: кнопка цитирования не для ответа

Спасибо! А, если при этом еще и 1 товар оставить, тот, что с полной сцепкой, а все остальные дубликаты удалить?

vikttur

Удалить дубликаты:
- вручную - это вручную;
- автоматически - макросом;
- полуавтоматически - с помощью фильтра.
          В доп. столбец формула для фильтрации:
          =--(B2<>B1)
          Фильтровать, копировать нужные строки, вставить в другое место.

lexedunut

#8
vikttur а ведь можно воспользоваться кнопкой на панели управления: удалить дубликаты - ?

vikttur

lexedunut, как еще обратить Ваше внимание на замечание?
третий раз: не мучьте кнопку цитирования! Не для ответа она!!!
Бестолковой вставкой целого предыдущего сообщения Вы засоряете тему, затрудняете чтение и, как следствие, отдаляете помощь себе же.

Цитироватьведь можно воспользоваться кнопкой на панели управления: удалить дубликаты - ?
Кто мешает попробовать, а уже после этого спросить (если вопрос останется)?

lexedunut

vikttur, заметил - принял к сведению. Как где заведено: на многих форумах без цитирования не обойтись)
Все же - кнопка удалить дубликаты решает или с ней могут быть какие-либо трудности?

zs


vikttur

Цитироватьудалить дубликаты решает или с ней могут быть какие-либо трудности?
Выделить диапазон с формулами. Копировать, Вставить_как_значения
Выделить диапазон данных (с шапкой таблицы)
Данные-Удалить_дубликаты-Снять_выделение-поставить галку только на столбце с именем-ОК