Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Ошибка в формуле с условиями

Автор omon3, 28.01.2016, 21:43

« назад - далее »

omon3

В общем есть такая формула C3=ЕСЛИ(B3>=0;(0);(ЕСЛИ(B3<0 И ABS(B3)>=A3;(A3);(A3-ABS(B3))))), эксель ругается. В чем может быть проблема?

vikttur

(0) - зачем? Не обязательно каждое значение функции окружать скобками.

Ошибка: посмотрите справку по функции И:
И(раз;два;...;десять)

omon3

Спасибо, ошибка была с условием И.
=ЕСЛИ(B3>=0;(0);(ЕСЛИ(И(B3<0;ABS(B3)>=A3);(A3);(ABS(ABS(B3)-A3)))))

vikttur

#3
Я Вам писал о лишних скобках.
Еще. Не нужно проверять B3<0, ведь это уже проверено в первом условии:
=ЕСЛИ(B3>=0;0;ЕСЛИ(ABS(B3)>=A3;A3;ABS(ABS(B3)-A3)))
И сокращаем еще:
=ЕСЛИ(B3>=0;0;ЕСЛИ(ABS(B3)>=A3;A3;ABS(A3+B3)))
возможно, даже без ABS в конце (при А3>0)

omon3

про скобки учту.(главное чтобы все работало) :)