Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Как рассчитать итоги и подитоги в таблице

Автор Светлана Иванова, 20.04.2016, 10:11

« назад - далее »

Светлана Иванова

Добрый день.
помогите решить задачу : есть массив данных более 50 тыс строк - магазины.Итоги в таблице рассчитываю через формулу суммесли , так как считаю по четырем показателям - продажи, остатки , заказ, оборачивемость.
если через фильтр выбирают конкретный магазин , то в строке итоги все равно считается итого по всему массиву
что я делаю не правильно?

vikttur

Цитироватьчто я делаю не правильно?
Не показываете файл-пример и пишете "неправильно" двумя словами :)

По задаче: ищите решения с функцией ПРОМЕЖУТОЧНЫЕ.ИТОГИ

NooBasTiK

Есть функция =ПРОМЕЖУТОЧНЫЕ.ИТОГИ но я не помню может она по параметрам складывать.

Светлана Иванова

я нарисовала свой пример
если считать через функцию промежуточные итоги, то в итого суммируются два показателя, что неверно.
поэтому изначально и считала через суммесли, но она не работает с применением фильтров

сорри  за орфографию - мало сплю

vikttur

В картинку формулу не вставить.
Предлагаете создать файл и внести данные с Вашего рисунка?

Светлана Иванова


vikttur

покатаель=показатель?
Какой результат нужен?

Светлана Иванова

итого сумма по всем магазинам и городам
итого по одному городу по всем тт

vikttur

=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(D1;СТРОКА(2:9)-1;))*(A2:A9=H1))

Светлана Иванова

если применить предложенную формулу , то итоги считаются и по показателю х и по у
это не верно .... нужен отдельный итог по х и отдельный итог по у
при чем сам итог при работе с фильтрами естественно считаться не должен  ??? ??? ??? ??? ???

vikttur

#10
Цитироватьитого по одному городу по всем тт
Об отдельных показателях - между строк не нашел. Я не умею читать мысли на расстоянии.
Посмотрите формулу... добавьте любые условия...
*(A2:A9=H1) - это одно условие.

Светлана Иванова

спасибо, вектор ясен пойду копать дальше  :)