Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

подсчет количества значений удовлетворяющих условиям

Автор Olechka, 21.04.2016, 10:51

« назад - далее »

Olechka

Добрый день! Помогите, пожалуйста, с формулой(((. У меня есть таблица (график выходов по дням). Нужно посчитать сколько в конкретный день на работе было работников с конкретным допуском (например 4 рабочих мест, на каждое раб. место нужен конкр. допуск) и еще, нужно подсчитывать только смены из перечня.

cheshiki1

так?
=СУММПРОИЗВ(ЕТЕКСТ(ИНДЕКС($C$14:$H$24;;ПОИСКПОЗ($B27;$C$12:$H$12;)))*ЕТЕКСТ(I$14:I$24))

Olechka

Спасибо большое, за ответ, почти так!!! только нужно не все заполненные клеточки считать по дням, а только те дни которые он был на работе, в графике разнесен и отпуск и учеба (там  справа от таблички перечень смен которые нужно считать-д,у,н,н1,н2,др,ур,нр,н1р,н2р)..сама пытаюсь, ошибку выдает((

cheshiki1

=СУММПРОИЗВ(ЕТЕКСТ(ИНДЕКС($C$14:$H$24;;ПОИСКПОЗ($B27;$C$12:$H$12;)))*ЕЧИСЛО(ПОИСКПОЗ(I$14:I$24;$AY$15:$AY$24;)))

Olechka