Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Растянуть формулу при ссылке на другой лист

Автор Tigran Dallakyan, 15.06.2016, 01:23

« назад - далее »

Tigran Dallakyan

Здравствуйте :
Решил сделать сводную таблицу затрат и столкнулся с трудностью, а именно
Есть затраты , разделены помесячно, в первом листе это все суммируется, но что бы не вводить формулы снова и снова меняя лист , прошу вашей помощи ,как растянуть формулу так что бы она сама меняла лист :
Общий лист

Пример Ячейка D2  формула =СУММ(Январь!$F$2:$L$2) ,   
Где Январь = Наименование листа и таких листов будет немерено, как правильно оформить формулу, что бы при растягивании формулы по строкам на E2,F2.... лист автоматически менялся на Февраль, март , апрель, все остальное как видно по формуле будет неизменным. К листам конечно можно добавить переменную 1,2,3,4 , если реализовать просто по месяцам проблематично.

Подскажите пожалуйста, находил похожую тему на форуме, но как не крутил предложенную формулу, получить результат не вышло... :-\

vikttur

=СУММ(ДВССЫЛ(D$1&"!F2:L2"))
В шапке таблицы должны быть наименования листов. Т.е. или листы переименовать месяцами, или месяцы в шапке заменить цифрами.

Цитироватьтаких листов будет немерено
ДВССЫЛ летуча (пересчитывается при любом изменении на листе). при большом количестве таких формул возможны тормоза при любом чихе над листом.
Формулами по-другому не решить. Нет... можно, конечно, вручную прописать ссылки на листы :)
Пора на макросы смотреть. или менять подход к построению таблицы и вычислениям.

Tigran Dallakyan

#2
кнопка цитирования не для ответа [МОДЕРАТОР]

Спасибо, я примерно так и сделал, шапка таблицы = имени листа, просто когда крутил вертел формулы чуток сбилось , сейчас по пробую, отпишусь, вы не против если не получится я к вам обращусь за советом ??