Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Корректировка экспортированной таблицы (объединение данных разбитых на 2 стр.)

Автор gregory9791, 07.07.2016, 11:24

« назад - далее »

gregory9791

При экспорте табличных данных в exel из txt получилось так, что в трех колонках данные, которые должны были отражаться в одной строке разбились на несколько строк (ячеек). Задача: объединить эти данные так, чтобы во всех колонках они были одной строкой. Пример во вложении. Лист исх. данных и лист с необходимым результатом.

Заранее спасибо за помощь.

runner

Иногда проще исправить структуру в исходном текстовом файле

gregory9791

Прикладываю исходный файл. На самом деле возможно будет проще.

runner

Текст не помог  :(
В пример для корректировки,
в ячейку H2 и растянуть вниз
=ЕСЛИ(ОСТАТ(СТРОКА();2)=1;A1&ТЕКСТ(A2;"ДД.ММ.ГГГГ");"")
в ячейку I2 и растянуть вниз
=ЕСЛИ(ОСТАТ(СТРОКА();2)=1;B1&B2;"")

Хвосты в формулах зависят от формата вторых строк.

Корявый колхоз, конечно, но, может, выручит

gregory9791

Вообще то, как мне кажется, здесь нужен макрос объединяющий ячейки в колонках, где данные разбиты на несколько строк ориентируясь на колонку с данными по одной строке.

runner

"Вам "шашечки" или ехать?" (с)
Макрос или решение задачи? Задача должна быть решена только определённым путем?
"колхоз" не работает или есть что-то за пределами примера, что мешает процессу?