Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Среднее время ответа в ч:мм сотрудника

Автор Anastasiya_M, 11.07.2016, 14:00

« назад - далее »

Anastasiya_M

Помогите, пожалуйста, найти среднее время ответа на сообщение по определенной тематике.
Возможно ли это сделать автоматически, например в сводной в столбце I будет выходить расчет среднего времени по одной тематике  из столбца D.
Заранее большое спасибо за помощь.
Файл во вложении.

vikttur

Формула среднего должна выдавать число, а не текст. Например:
=(B2-A2)*1440
Формула для сводной:
=СРЗНАЧЕСЛИМН($D$2:$D$28;$C$2:$C$28;H5)
или формула массива (вводится тремя клавишами):
=СРЗНАЧ(ЕСЛИ($C$2:$C$28=H5;$D$2:$D$28))

Можно Вашу формулу оставить и применить для сводной такую:
=СРЗНАЧ(ЕСЛИ($C$2:$C$28=H5;--$D$2:$D$28))
Но лучше данные хранить в родном формате (числа в числовом).

iron priest