Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Как выбрать следующую ячейку после той, которую выдает формула ВПР?

Автор Antohnio, 09.08.2016, 13:50

« назад - далее »

Antohnio

Здравствуйте, коллеги, мудрецы, программисты)))
Я новичок на форуме, помогите))

Дано: есть столбец с датами - столбец С.  Есть другой столбец с другими датами - Q.
Задача: найти формулу, которая бы выбирала из первого столбца первую по списку дату позднее заданной в столбце Q.

Моя попытка решения: для начала использую формулу ВПР(Q6;$C$6:$C$30;1;ИСТИНА). Эта формула выдает дату равную заданной в Q6 или ранее идущую.
Теперь осталось-то только добавить что-то, чтобы формула брала следующую по списку дату в столбце C. 
Но не получается!
Формула =Смещ(ВПР(Q8;$C$6:$C$30;1;ИСТИНА);0;1)   почему-то выдает ошибку и не хочет работать.
Формула =ДВССЫЛ("C"&СТРОКА(ВПР(Q8;$C$6:$C$30;1;ИСТИНА)))   тоже выдает ошибку. 
Я что-то делю не так или Эксель просто взбунтовался?

Antohnio

не получается вообще найти координаты ячейки, которую находит формула ВПР.
например, формула =ВПР(Q6;$C$6:$C$30;1;ИСТИНА)  работает верно.
Но не работает даже простая комбинация  с ней  = Строка(ВПР(Q6;$C$6:$C$30;1;ИСТИНА))  Не выдает номер строки ячейки. Выдает ошибку - почему?

cheshiki1

по идее вам нужна формула такого вида ИНДЕКС(столбец;ПОИСКПОЗ(дата;столбец дат;)+1)
более точно можно сказать при наличии файла примера.

Antohnio

Спасибо большое!   ;D
Действительно помогло!     ;)
потестим файлик конечно, на ошибки, но вроде работает ))))
Вопрос закрыт, кажется.

Ради удовлетворения любопытства только хочется узнать, почему с ВПР вышеуказанные формулы "Строка", "Смещ", "ДВССЫЛ" не работали?   ???

cheshiki1

ВПР выдает ответ значение, а для работы ф-ций "Строка", "Смещ", "ДВССЫЛ" нужна ссылка.

vikttur

Внимательнее справку читайте:
СТРОКА([ссылка])
ВПР показывает значение, а не ссылку

Antohnio

Я думал о том, что ВПР дает значение.
А как тогда найти координаты ячейки, ИЗ которой впр берет значение?

cheshiki1

1 вопрос одна тема.
из ВпР точно координаты не вытянете, а вот ПОИСКПОЗ даст вам номер строки найденного значения. от неё и пляшите.

Antohnio