Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Массовый поиск и замена

Автор byters, 20.08.2016, 13:53

« назад - далее »

byters

Ребят, подскажите как осуществить массовый поиск и замену текста?
Есть 2 листа Excel. В листе №1 есть поля _ID_ и _SKU_, в листе №2 есть поле product_id(оно равно значению поля _SKU_ из 1 листа).
Необходимо чтобы во 2 листе все значения поля product_id заменились на соответствующие значения поля _ID_ из 1 листа.
На конкретном примере из приложенного файла:
В 1 листе _ID_ 1165 присвоен _SKU_ 13225847, во 2 листе в поле product_id есть 2 значения равные 13225847.
Соответственно необходимо чтобы во 2 листе все значения поля product_id равные 13225847 заменились на 1165.



Pelena

В доп. столбец формулу
=ИНДЕКС(Лист1!$B$2:$B$3;ПОИСКПОЗ(B2;Лист1!$D$2:$D$3;0))
Затем можно скопировать -- Вставить как значения в столбец В

byters

У меня почему-то Н/Д на следующих значениях вылазиет. Подскажите в чем проблема?

Serge 007

=ИНДЕКС(Лист1!B$2:B$897;ПОИСКПОЗ(B2;Лист1!D$2:D$897;))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

byters

Огромное Вам спасибо! Избавили от многочасовой рутины!