Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Изменить формат ячеек с датой, записанной текстом

Автор Kirill G., 07.09.2016, 19:55

« назад - далее »

Kirill G.

Друзья,
посмотрите пожалуйста вложенный файл
Ячейки  с августом месяцем меняются на любой заданный формат, а ячейки с июлем месяцем формат не меняют (то-есть вообще никакому форматированию не поддаются)
 
Как мне преобразовать ячейки с июлем чтобы была также возможность менять форматирование?

=ТЕКСТ(А1;ДД.ММ.ГГГГ) не работает
замена 2 - 2 (обновление данных) не работает
сохранение в текстовый файл и затем обратное копирование - не работает


Serge 007

Цитата: Kirill G. от 07.09.2016, 19:55...=ТЕКСТ(А1;ДД.ММ.ГГГГ) не работает...
Такая формула будет работать:=ВЫБОР(1+ЕЧИСЛО(A1);ДАТА(ПРАВБ(A1;4);ЛЕВБ(A1;ПОИСК(".";A1)-1);ПСТР(A1;ПОИСК(".";A1)+1;ПОИСК(".";A1;ПОИСК(".";A1)+1)-(ПОИСК(".";A1)+1)));A1)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

vikttur

=--ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПРАВСИМВ(A1;7);".";"."&ЛЕВСИМВ(A1;ПОИСК(".";A1)));A1)
=--ЕСЛИОШИБКА(ЗАМЕНИТЬ(ПРАВСИМВ(A1;7);4;;ЛЕВСИМВ(A1;ПОИСК(".";A1)));A1)
Но что Вы будете делать с такой датой: 1.12.2016? Это начало декабря или середина января? Тут не только формула - человек не поймет, ведь в одном диапазоне хранятся данные разных форматов.

Serge 007

Цитата: vikttur от 07.09.2016, 22:17...1.12.2016? Это начало декабря или середина января?..
Виктор, судя по файлу и описанию задачи это середина января (12.01.2016)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

vikttur

Судя по данным, это может быть и одно, и другое. Но это проблема не наша :)

Serge 007

Цитата: vikttur от 07.09.2016, 22:56...Судя по данным, это может быть и одно, и другое...
Нет, не может быть, тут однозначный алгоритм просматривается...
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

vikttur

Да, понял. Считал, что нижние даты тоже текстом записаны