Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Поиск наибольшего, если значения в другом столбце равны

Автор Cobalt, 17.10.2016, 20:41

« назад - далее »

Cobalt

Буду очень признателен за помощь. В файле 3 столбца: дата, имя, значение. Задача автоматизировать поиск наибольшего значения для каждой даты и выделить (цвет ячейки, шрифт или любой символ в свободной ячейке в той же строке) имя, которое соответствует наибольшему значению.
Т.е. в файле во вложении для 01.01.15 наибольшее значение 617 и ему соответствует имя ААА; для 02.01.15 наибольшее значение 775 и ему соответствует имя RRR; для 03.01.15 значение 725 и имя TTT.
В итоге надо получить "отметку" для имён AAA, RRR и ТТТ. Подскажите пожалуйста как?

Pelena


Cobalt

Цитата: Pelena от 18.10.2016, 09:27
условное_форматирование подойдёт?
Суть абсолютно верная, спасибо большое! Но что-то уж больно тормозит... У меня в файл 63000 строк, попробовал для на 6000: при добавлении фильтров ооочень долго всё обдумывается. Хотя по сути наверное другие вариантов и нет?

Pelena


zs5

#4
формула для определения в столбце наибольшого значения среди массивов равных значений:
=ЕСЛИ(ИЛИ(A9=A8;A8=0);ЕСЛИ(НАИБОЛЬШИЙ($C$4:ИНДЕКС($A$4:A24;СЧЁТЕСЛИ($A$4:A24;A9);1);1)=C9;B9;0);ЕСЛИ(A9>A8;ИНДЕКС(A4:C19;ПОИСКПОЗ(НАИБОЛЬШИЙ(СМЕЩ($C$4;СЧЁТЗ($A$4:A8);0):СМЕЩ(ИНДЕКС($A$4:A24;СЧЁТЕСЛИ($A$4:A24;A9);1);СЧЁТЗ($A$4:A8);0);1);C4:C19;0);2);C8))