Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Сравнение двух дат

Автор Shavkat Khalikov, 31.10.2016, 10:43

« назад - далее »

Shavkat Khalikov

Добрый день.

Нужен макрос.
Имеются 2 даты в двух ячейках. Даты не фиксированные.
Необходимо сравнить дату в ячейке А с датой в ячейке В, но на 15 дней вперед. И выдать сообщение об ошибке.
Например. Дата в ячейке А "10-Мар-16" в ячейке В "20-Мар-16" то Неверно, если дата в ячейке В " 25-Мар-16" то верно.

Спасибо


TimSha

Цитата: Shavkat Khalikov от 31.10.2016, 10:43
... И выдать сообщение об ошибке...
С этим вполне справится "Проверка данных". Как вариант... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

Shavkat Khalikov

Необходимо также чтобы проверка происходила по нажатию кнопки.

TimSha

Она - проверка - и без кнопок работает... ;)
ps Если же это учебно-тренировочное задание, то приложите хоть какую-то свою попытку сделать, а нет - заказываете решение фрилансерам. И обычно к хотелке/заданию принято файл-пример прикладывать.
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

IKor

Вероятно того же результата можно добиться и при помощи макроса, но на мой взгляд достаточно и формул...
Если даты записаны в числовом формате (а не текстом!), то к ним применимы любые арифметические действия, включая сложение и сравнение:
=ЕСЛИ(B1-A1>15;"верно";"не верно")

При желании ту же логику можно реализовать и в макросе.

Serge 007

Цитата: IKor от 31.10.2016, 12:44...Если даты записаны в числовом формате (а не текстом!)...
А если текстом, то в макросе можно предусмотреть проверку IsNumeric и для текста написать алгоритм перевода в число. Важно только что бы формат текстовой записи дат всегда был одинаковый
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

zs5

=ЕСЛИ(ДЕНЬ(A1+15-C1)=0;"верно";"неверно")
P.S. Формат общий