Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Время на каждый заказ по каждому работнику и по всем работникам

Автор Николай Мельничук, 19.11.2016, 23:50

« назад - далее »

Николай Мельничук

Здравствуйте!
Приходится делать распределение времени сдельных нарядов по заказам. Из бумажного наряда на сдельную работу беру информацию (ф.и.о работника, номер заказа и время, затреченное на заказ), далее в ручную собираю время на каждый заказ по каждому работнику, далее собираю общее время на каждый заказ, затраченное всеми работниками, опять в ручную. Процесс довольно длительный, делаю в экселе, но практически без формул, подскажите, возможно ли что-то ускорить в этом случае? Файл прикреплён.

Юрий_brv


Николай Мельничук


vikttur

#3
В правилах написано о названии темы. Крики о помощи - это не название темы.
До устранения замечания помощь приостановлена (правила разрешают удалить тему!).
Решение есть.

kuklp1

Название звучит как приказ. ???
Я, как всегда, чертовски адекватен... Email: kuklp60@gmail.com WM Z206653985942, R334086032478, U238399322728, E332314026771

zs5

Пора вводить формулообмен

Иван Иванов

Решение с использованием сводных таблиц и выборки из списка

см. вложение

vikttur

Для одного работника:
=СУММЕСЛИ($A$4:$A$11;A19;$B$4:$B$11)
Для заказа:
=СУММЕСЛИ($A$4:$H$12;C30;$B$4:$I$12)


Иван Иванов, хоть и разрешены файла до 1 Мб, но зачем? И это при исходном файле автора в 13 кБ?

boa

Цитата: Иван Иванов от 20.11.2016, 18:16
Решение с использованием сводных таблиц и выборки из списка
А файл "раздулся" за счет внесения  в именованный список "Работники" целой колонки
измените формулу списка на динамическую и файл "усохнет" до 40kb

=OFFSET(Работники!R1C1;0;0;COUNTA(Работники!C1);1)
=СМЕЩ(Работники!R1C1;0;0;СЧЁТЗ(Работники!C1);1)
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра