Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Суммирование с текстовыми значениями как числовыми

Автор Анатолий, 27.11.2016, 00:10

« назад - далее »

Анатолий

Коллеги!
Как вычислить одной формулой следующую задачу (вместо цифр местами, текстовые штрихи). См файл.
Даны размеры прямоугольников, необходима учесть длину нужных сторон. Если указан один штрих: " /" это одна сторона учитывается, если указано: "//" это две стороны учитываются, если нет данных в ячейке значит не учитываются эти стороны.

vikttur

формула массива, вводится тремя клавишами:
=СУММ((B7:B10*ДЛСТР(C7:C10)+D7:D10*ДЛСТР(E7:E10))*F7:F10)

zs5

=(ЕСЛИ(СОВПАД("/";C9);B9*1;ЕСЛИ(СОВПАД("//";C9);B9*2;0))+ЕСЛИ(СОВПАД("/";E9);D9*1;ЕСЛИ(СОВПАД("//";E9);D9*2;0)))*ЕСЛИ(ИЛИ(И(СОВПАД("/";C9);СОВПАД("//";E9));И(СОВПАД("//";C9);СОВПАД("/";E9)));1;2)