Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Не суммирует время

Автор lapin9126, 19.12.2016, 18:00

« назад - далее »

lapin9126

Здравствуйте. Собственно проблема такая: при вводе значений для суммирования времени в формате 06:08:23:15(часы, минуты, секунды, доли секунд), пишет #ЗНАЧ! Менять формат ячейки пробовал.

vikttur

Формат ячейки - только визуальное отображение значения. Может не совпадать с типом значения.
Проверьте:
=ЕЧИСЛО(A2)
Покажет ЛОЖЬ - в ячейке текст
В Excel нет формата "доли секунд". Значения нужно преобразовывать в число.
Доли секунд - 1/60 или 1/100?

lapin9126


vikttur

#3
=ЛЕВБ(A2;8)+ЛЕВБ(B2;8)+(ПРАВБ(A2;2)+ПРАВБ(B2;2))/5184000
5184000 = 24*60*60*60 - часов*минут*секунд*долей. Смысл:
к-во_долей/вес_одной_доли_в_сутках, или
к-во_долей*часть_суток (1/вес_одной_доли_в_сутках)

lapin9126

Спасибо, вроде считает, но доли секунд не показывает в результате. Досада.

zs5

=ЗАМЕНИТЬ(A2;7;2;ПРАВСИМВ(ПСТР(A2;1;8);2)+ПРАВСИМВ(ПСТР(B2;1;8);2))

vikttur

Доли секунд можно добавить, но это будет опять текст, не число.

lapin9126

Цитата: zs5 от 19.12.2016, 19:06
=ЗАМЕНИТЬ(A2;7;2;ПРАВСИМВ(ПСТР(A2;1;8);2)+ПРАВСИМВ(ПСТР(B2;1;8);2))
Тоже считает до секунд, доли тоже не учитыват.

zs5

#8
=ЗАМЕНИТЬ(ЗАМЕНИТЬ(A2;7;2;ПРАВСИМВ(ПСТР(A2;1;8);2)+ПРАВСИМВ(ПСТР(B2;1;8);2));10;2;ПРАВСИМВ(ПСТР(A2;1;11);2)+ПРАВСИМВ(ПСТР(B2;1;11);2))

lapin9126

Огромное спасибо за помощь, буду как-то выкручиваться другими методами  :(

vikttur

С добавлением целых секунд, полученных при суммировании долей:=ТЕКСТ(ЛЕВБ(A2;8)+ЛЕВБ(B2;8)+ЦЕЛОЕ((ПРАВБ(A2;2)+ПРАВБ(B2;2))/60)/86400;"чч:мм:сс")&":"&ТЕКСТ((ПРАВБ(A2;2)+ПРАВБ(B2;2))/86400;"сс")
Если при суммировании долей целых секунд не будет (как в примере), можно удалить часть формулы:
+ЦЕЛОЕ((ПРАВБ(A2;2)+ПРАВБ(B2;2))/60)/86400

lapin9126

УРАААААААААААААА!!!! Заработало!!!!!!!!!!!!!!!!!!!!!!!!! СПАСИБООООО!!!!!!!