Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Группировка дат

Автор Татьяна Ящук, 21.12.2016, 22:37

« назад - далее »

Татьяна Ящук

Добрый вечер, нужна ваша помощь.
Думаю вопрос не сложный для тех, кто работает в Exel
Заранее благодарю за ответ.
Есть столбец с двойными датами
07-08 октября 2017
10-12 июня 2017
13-14 мая 2017
14 января 2017
15 июля 2017
15-16 июля 2017
16-17 сентября 2017
17 августа 2017
22-23 апреля 2017
23 февраля 2017
25 февраля 2017
25-26 марта 2017
27-28 мая 2017
29-30 апреля 2017
Как упорядочить от января до декабря и чтобы числа были по порядку?

zs5

Название месяца желательно в именительном падеже,потому что дополнительные хлопоты с названием месяца. А так как вариант - в дополнительном столбце отобразить даты по формуле, а затем сортировка:=ДАТА(ПРАВСИМВ(A9;4);МЕСЯЦ(ЗАМЕНИТЬ(ПСТР(A9;ПОИСК(" ";A9)+1;ДЛСТР(A9)-5-(ПОИСК(" ";A9)));1;1;"А")&" "&2017);ПСТР(A9;ПОИСК(" ";A9)-2;1)&ПСТР(A9;ПОИСК(" ";A9)-1;1))

vikttur

Столбец для сортировки:
=--(ЛЕВБ(A1;2)&ПОДСТАВИТЬ(ПСТР(A1;ПОИСК(" ";A1);4);"ая";"ай")&ПРАВБ(A1;5))

zs5

Если стандартный ввод данных и брать максимальную дату в интервале, то можно так:=ЕСЛИОШИБКА(--(ПСТР(A6;4;2)&ПОДСТАВИТЬ(ПСТР(A6;ПОИСК(" ";A6);4);"ая";"ай")&ПРАВБ(A6;5));--(ЛЕВБ(A6;2)&ПОДСТАВИТЬ(ПСТР(A6;ПОИСК(" ";A6);4);"ая";"ай")&ПРАВБ(A6;5)))

dsNiper

Вопрос со схожей тематикой:
смысл - сделать одним из условий подсчета значений - дату (значения к которым относится дата, которая позже определенной, в примере - позже 30.12.2015).
простым решением будет написать =СЧЁТЕСЛИ(R[-5]C[-2]:R[-3]C[-2];">30.12.2015").
Но как написать, не указывая дату в самой формуле, а указывая в формуле ссылку на ячейку с датой, соответствие которой будет проверяться. если указать: =СЧЁТЕСЛИ(R[-5]C[-3]:R[-3]C[-3];">R[-6]C") (при том, что в ячейке R[-6]C будет стоять, условно, дата 30.12.2015, подсчет осуществляться не будет...

boa

Цитата: dsNiper от 24.01.2017, 13:51
=СЧЁТЕСЛИ(R[-5]C[-3]:R[-3]C[-3];">R[-6]C")

=СЧЁТЕСЛИ(R[-5]C[-3]:R[-3]C[-3];">"&R[-6]C)
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

dsNiper

#6
СПАСИБО ОГРОМНОЕ!!!